Outgoing IP on Blacklist
Incident Report for Manage Protect Pty Ltd
Resolved
This issue is now resolved.
Posted about 1 month ago. Aug 08, 2017 - 14:50 AEST
Identified
One of our outgoing IPs has been added to a blacklist which is affecting outgoing emails to hotmail.com addresses.
Please let us know if you are adversely affected so we can reroute your outbound address.
Posted about 1 month ago. Aug 08, 2017 - 14:01 AEST