IP address 52.62.123.207 blacklisted by ProofPoint - Outbound affected only.
Incident Report for Manage Protect Pty Ltd
Resolved
We have been informed that the blacklist has removed our IP address and monitoring has shown no more issues.
Posted 3 months ago. Feb 18, 2019 - 16:08 AEDT
Monitoring
It has come to our attention that a number of users are experiencing problems sending email through MPmail. We are aware that Proofpoint has added our IP address to their blacklist. We are currently working to have it removed. Notification will be sent when Proofpoint have lifted the block
Posted 3 months ago. Feb 15, 2019 - 15:44 AEDT
This incident affected: MPmail.