MPexchange - Non-Australian Server Only Degraded Performace
Incident Report for Manage Protect Pty Ltd
Resolved
The clients affected by this routing issue are no longer having issues. We have run traceroutes and the packet loss is no longer an issue.
Posted 5 months ago. Apr 11, 2017 - 11:10 AEST
Investigating
Customers on US Exchange infrastructure may experience slow connections or disconnections. We are aware of this, we suggest either tethering to mobile phone or 4G router, as performance will improve on these devices. We are seeing packet loss through Hurricane Electric in the US.

Please note if you are on MBX690 (Australian server) you will be having no issue.
Posted 6 months ago. Apr 03, 2017 - 13:07 AEST