Office 365 https://portal.office.com is down
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 30, 2019 - 09:00 AEDT
Monitoring
https://portal.office.com is currently unavailable. We will keep you updated with any developments.
Posted 4 months ago. Jan 30, 2019 - 08:40 AEDT
This incident affected: Office 365.