MPmail Flash Control Panel
Incident Report for Manage Protect Pty Ltd
Resolved
The cause of the incident has been resolved. The Flash Control Panel is again fully operational.
Posted May 21, 2020 - 11:44 AEST
Investigating
The Flash Control panel is not rendering currently. We are investigating now.

Note: The HTML portal is functional and is available at https://mpmail.com.au please reach out to support@manageprotect.com if you need access configured for the HTML portal.
Posted May 21, 2020 - 10:50 AEST
This incident affected: MPmail.