MPexchange Connections Issues
Incident Report for Manage Protect Pty Ltd
Resolved
An upstream ISP issue has been identified and a resolution put in place.
We apologise for any inconvenience during this time.

Please let support know if you experience any further issues with your Outlook sending/ receiving and/ or connecting to webmail.manageprotect.com

1300 657 500
support@manageprotect.com
chat.manageprotect.com
Posted 7 months ago. Oct 22, 2018 - 17:58 AEDT
Update
The Network Team are working on mitigating upstream routing issues.
In the meantime, access to webmail.manageprotect.com should provide intermediate access to emails. If you are having issues connecting to that, please try the alternate webmail address: https://owa.msoutlookonline.net/
Please email support@manageprotect.com if you have specific issues accessing webmail.

1300 657 500
support@manageprotect.com
chat.manageprotect.com
Posted 7 months ago. Oct 22, 2018 - 13:46 AEDT
Investigating
We are investigating issues with customers connecting to MPexchange. This includes local Outlook timing out to the server and connecting to OWA (webmail.manageprotect.com).

If you are experiencing issues, please perform a traceroute to mail.aus.exch690.serverdata.net and send to support@manageprotect.com as well as any other supporting information.
Posted 7 months ago. Oct 22, 2018 - 11:14 AEDT
This incident affected: MPexchange.