MPexchange/Business365 potential login issues
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted Nov 19, 2019 - 09:06 AEDT
Update
All MPexchange / Business365 2FA authentication issues for login to OWA have now been resolved.
We apologise for any inconvenience.
Posted Nov 19, 2019 - 09:05 AEDT
Monitoring
The upstream provider has informed us that the login page for OWA(webmail) is having issues when coupled with 2 factor authentication, causing a 504 Gateway timeout error.
The root cause has been identified and we expect a fix to be applied soon.
Posted Nov 19, 2019 - 08:37 AEDT
This incident affected: MPexchange.