MPmail Blacklist
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted 5 months ago. Feb 11, 2019 - 08:16 AEDT
Monitoring
Our outbound IPs now appear to be delisted by Proofpoint.
We will continue to monitor.

Please let support know if you are experiencing any further issues.

support@manageprotect.com
chat.manageprotect.com
1300 657 500
Posted 5 months ago. Feb 08, 2019 - 12:05 AEDT
Investigating
We are investigating reports of one of MPmail's outbound IP's listed with proofpoint.
If you are experiencing issues, please reach out to support.

support@manageprotect.com
chat.manageprotect.com
1300 657 500
Posted 5 months ago. Feb 07, 2019 - 17:38 AEDT
This incident affected: MPmail.