manageprotect.com issue. DNS related services affected
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted Mar 09, 2020 - 09:30 AEDT
Identified
The manageprotect.com domain is currently having issues.
We are working to correct this asap.
Posted Mar 09, 2020 - 09:07 AEDT
This incident affected: MPmail, MPexchange, and MParchive.