Can't view Backup365 backups in converge.mp
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted Jan 23, 2020 - 15:19 AEDT
Investigating
Backup365 sites and mailboxes continue loading and do not display in Converge.
Posted Jan 23, 2020 - 14:34 AEDT
This incident affected: Backup365 and Converge.