MPmail / Office 365 Exchange Outbound Issues
Incident Report for Manage Protect Pty Ltd
Resolved
The additional IP has now been successfully added and has propagated across our servers.
As such, outbound mail will now start to flow as normal.

If you have further issues, please contact support.

support@manageprotect.com
chat.manageprotect.com
1300 657 500
Posted 3 months ago. Dec 05, 2018 - 13:38 AEDT
Identified
Microsoft have added an extra IP range to their list of outbound IPs today. However, they did not update their SPF record.
This has caused emails out from O365 to MPmail to get caught at the Exchange.
We have now added the Microsoft IP to our outbound IPs so that mail will flow while we wait . Currently waiting for propagation of this change.
Further updates to follow.

support@manageprotect.com
chat.manageprotect.com
1300 657 500
Posted 3 months ago. Dec 05, 2018 - 13:08 AEDT
This incident affected: MPmail.