MPMail V2 Control Panel performance degraded
Incident Report for Manage Protect Pty Ltd
Resolved
The MPMail V2 Control Panel has been restored to full functionality. If you continue experiencing issues please contact support - support@manageprotect.com or call 1300 657 500.
Posted 10 months ago. Nov 10, 2016 - 16:58 AEDT
Identified
We have identified an issue in the MPMail v2 Control Panel that is currently affecting Workspace features and causing intermittent security disconnects. Our engineers are already working to correct this issue and we expect Control Panel functionality to return to normal shortly.
Posted 10 months ago. Nov 10, 2016 - 16:18 AEDT