Office 365 Messages being deferred
Incident Report for Manage Protect Pty Ltd
Resolved
Office 365 had an issue with relaying email from external users.

The root cause stated by Microsoft was as follows:
A monitor that checks the health of the infrastructure that facilities mail flow from external users is not operating as intended.

If you had continuity service through MPMUA, Microsoft has now rectified the issue and all mail caught in the continuity service is being automatically relayed to intended recipients. This requires no action on your part.
Posted Nov 20, 2019 - 07:30 AEDT
Update
We are continuing to work with the upstream engineers.
Posted Nov 19, 2019 - 20:40 AEDT
Update
It has been determined to be a Microsoft issue. We are testing resolution. Advise shortly.

-19/11/2019 4:42:57 PM

Title: Problems receiving mail

User Impact: Users may not receive emails sent from external users.

More info: Messages sent internally between users are not impacted.

Current status: We've disabled a monitor that facilitates mail flow from external users that we suspect was causing impact. We're validating whether this action has resolved the issue.

Scope of impact: This issue could potentially impact any users receiving emails from external users.

Root cause: A monitor that checks the health of the infrastructure that facilities mail flow from external users is not operating as intended.

Next update by: Tuesday, November 19, 2019, at 7:30 AM UTC

-19/11/2019 3:42:16 PM

Title: Problems receiving mail

User Impact: Users may not receive emails sent from external users.

More info: Messages sent internally between users are not impacted.

Current status: We suspect there is a networking issue that is causing impact. We're continuing our investigation of network logs.

Scope of impact: This issue could potentially impact any users receiving emails from external users.

Next update by: Tuesday, November 19, 2019, at 7:30 AM UTC

-19/11/2019 2:33:43 PM

Title: Problems receiving mail

User Impact: Users may not receive emails sent from external users.

More info: Messages sent internally between users are not impacted.

Current status: We're currently analyzing system logs to better understand the issue and determine our next steps.

Scope of impact: This issue could potentially impact any users receiving emails from external users.

Next update by: Tuesday, November 19, 2019, at 5:30 AM UTC
Posted Nov 19, 2019 - 16:55 AEDT
Update
The issue appears to have commenced around 2pm today AEDT. It appears to be an intermittent issue between MPmail and Office 365. This is not impacting MPexchange or other MPmail tenants. Messages that are deferred will retry and deliver once the issue has been resolved. These are visible in the MPmail portal.

Messages are also accessible through individual users "archive" tab in MPmail or through message continuity at: https://webmail.mpmail.com.au/ We have escalated this to both MS & MPmail ops centres.
Posted Nov 19, 2019 - 15:48 AEDT
Investigating
We are seeing intermittent messages being deferred destined to Office 365. The error we are seeing is "421 Syntax error, command unrecognised". We are investigating this with Microsoft, and will advise more shortly.
Posted Nov 19, 2019 - 15:32 AEDT
This incident affected: MPmail and Office 365.