Greylisted IP address
Incident Report for Manage Protect Pty Ltd
Resolved
Our IP has been removed from the greylist. Mail can now be sent freely.
Posted 5 days ago. Mar 14, 2019 - 07:31 AEDT
Identified
One of MPmail's outbound IP addresses has been greylisted by Bitninja. We are working on getting it removed.

Please contact support if you have further concerns

support@manageprotect.com
chat.manageprotect.com
1300 657 500
Posted 6 days ago. Mar 13, 2019 - 12:33 AEDT
This incident affected: MPmail.