https://control.manageprotect.com unavailable
Incident Report for Manage Protect Pty Ltd
Resolved
MPmail now available.
Posted Sep 12, 2019 - 14:34 AEST
Investigating
We are currently investigating this issue.
Posted Sep 12, 2019 - 12:37 AEST
This incident affected: MPmail.