Microsoft 365 delivery issues
Incident Report for Manage Protect Pty Ltd
Resolved
Final update advising that email flow has been normal overnight (AEDT). We suspect that there was an internal issue with the Microsoft 365 (related to TLS) and was transient, however no formal confirmation from Microsoft at this stage. The MPmail infrastructure has been reviewed thoroughly and there were no failures or errors. Please reach out to support@manageprotect.com if you have any questions or issues related to this incident.
Posted Nov 18, 2020 - 09:12 AEDT
Monitoring
We have been monitoring the queues and the gates and the deferred emails are now being delivered, and queue numbers are falling to normal levels. All emails should be delivered now without any deferred emails. It seems very likely that Microsoft has resolved the TLS issues we identified previously however we will monitor the queues over the next few hours before resolving this incident.
Posted Nov 17, 2020 - 15:44 AEDT
Identified
We have identified that Microsoft is not accepting delivery of messages due to recent TLS changes. We are working closely with the upstream vendors to have this resolved. We can confirm that the deferred email queues are lowering slowly.

Will provide updates within the hour.
Posted Nov 17, 2020 - 14:55 AEDT
Update
We are continuing to investigate this issue.
Posted Nov 17, 2020 - 14:52 AEDT
Update
No major change to the delivery delays. Please note that outbound delivery flows are fine. Further, the inbound delays are limited to customer domains using both Microsoft 365 and MPmail other mail platforms such as MPexchange are fully functional. Will provide another update within the hour.
Posted Nov 17, 2020 - 13:45 AEDT
Update
We are working with all relevant upstream vendors and have confirmed that email messages are being delivered but are delayed. No messages are being rejected or lost. Will update this incident within the next hour.
Posted Nov 17, 2020 - 12:12 AEDT
Update
We are still investigating this issue. Will provide new updates within the hour.
Posted Nov 17, 2020 - 11:30 AEDT
Investigating
We have received reports that inbound mail isn't being received by some Microsoft 365 Exchange Online tenants. We can confirm we are also seeing this in our internal systems.

This is being followed up with the relevant parties and we will let you know when we have more information.
Posted Nov 17, 2020 - 09:46 AEDT
This incident affected: MPmail and Office 365.