MPmail Portal https://control.manageprotect.com not working
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted Sep 05, 2019 - 11:40 AEST
Investigating
https://control.manageprotect.com is currently not functioning as expected. We are working to correct this. If you require emails to be released, send an email to support@manageprotect.com with the sender, recipient and subject and we will endeavour to assist ASAP.
Posted Sep 05, 2019 - 11:33 AEST
This incident affected: MPmail.