MPmail - Control Panel Access
Incident Report for Manage Protect Pty Ltd
Resolved
The MPmail Control Panel is back up and you will be able to log in.
Posted 10 months ago. Jul 19, 2017 - 09:06 AEST
Identified
At this time you will be unable to login to the MPmail Control Panel. Our engineers are currently aware of the issue and working on a fix. We will update when the Control Panel is accessible again.
Posted 10 months ago. Jul 19, 2017 - 08:43 AEST