Support Cases not updating
Incident Report for Manage Protect Pty Ltd
Resolved
A fix has now been put in place.
The ticketing system is now working as expected.
We will respond to all new cases shortly.
Posted 8 months ago. Sep 26, 2018 - 09:54 AEST
Identified
Our ticketing system is currently failing to display new cases.
If you send an email to support@manageprotect.com you will receive a ticket number but we won't have visibility.
This issue has been identified and currently being worked on. Updates to follow.

If you have an urgent issue, please call support:
1300 657 500

Or chat:
chat.manageprotect.com
Posted 8 months ago. Sep 26, 2018 - 09:46 AEST
This incident affected: Service Desk & Support Systems.