MPMail V2 Control Panel performance degraded
Incident Report for Manage Protect Pty Ltd
Resolved
MPmail V2 Control Panel security disconnect issue has been resolved.
Posted 10 months ago. Jan 20, 2017 - 17:53 AEDT
Investigating
We are investigating issues with security disconnects when attempting to login to the MPmail v2 Control Panel.
Posted 10 months ago. Jan 20, 2017 - 17:00 AEDT