MPMail V2 Control Panel performance degraded
Incident Report for Manage Protect Pty Ltd
Resolved
Workspace Email Search now fully operational.
Posted 10 months ago. Jan 19, 2017 - 11:20 AEDT
Investigating
We are investigating an issue with the Workspace Email Search feature not returning results. Mail flow and other Control Panel features unaffected.
Posted 10 months ago. Jan 19, 2017 - 10:09 AEDT