Backup 365 Mailbox Sync
Incident Report for Manage Protect Pty Ltd
Resolved
This issue is now resolved.
Posted Dec 04, 2019 - 23:06 AEDT
Update
We've deployed a workaround that is helping reduce the impact, so backups are now resuming slowly. Will continue to work with Microsoft to push for a resolution on their affected services.
Posted Nov 27, 2019 - 13:14 AEDT
Identified
The issue has been identified

We're currently observing degraded performance of Microsoft's Office 365 email APIs, resulting is some reduced backup rates. Hosted Exchange services (MPexchange) and SharePoint / OneDrive are all unaffected. We're continuing to monitor.
Posted Nov 27, 2019 - 09:51 AEDT
Investigating
We're currently observing degraded performance of Microsoft's Office 365 email APIs, resulting is some reduced backup rates. Hosted Exchange services (MPexchange) and SharePoint / OneDrive are all unaffected. We're continuing to monitor.
Posted Nov 26, 2019 - 11:52 AEDT
This incident affected: Backup365.