Office 365 Provisioning currently unavailable
Incident Report for Manage Protect Pty Ltd
Resolved
Provisioning now working
Posted 12 months ago. Jul 25, 2018 - 08:50 AEST
Identified
We have identified an issue with our ability to provision Office 365 licenses. This issue affects provisioning through converge.mp and through the provisioning team. We will have this fixed as soon as possible.
Posted 12 months ago. Jul 25, 2018 - 08:08 AEST
This incident affected: Office 365.