MPmail V2 performance degraded
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 21, 2016 - 21:50 AEDT
Investigating
We have identified an issue with secondary mail server on 52.62.125.178 which we are currently investigating. More information to follow.
Posted 7 months ago. Dec 21, 2016 - 18:28 AEDT