MPmail Sending Blacklist
Incident Report for Manage Protect Pty Ltd
Resolved
Removed from BL's at 6:58am AEDT
Posted 8 months ago. Mar 29, 2017 - 07:28 AEDT
Identified
One of the MPmail outbound relays is currently on a blacklist, our engineers are aware and working on the issue.
Posted 8 months ago. Mar 29, 2017 - 06:36 AEDT