Email intermittently not being delivered
Incident Report for Manage Protect Pty Ltd
Resolved
The issue has been resolved and any missing emails will be delivered. Please reach out to support@manageprotect.com if you find any issues.
Posted Apr 09, 2020 - 19:47 AEST
Update
We are still working on this issue. As mentioned previously, mailflow is working normally for most customer domains but the issue is limited to a small set of recipients.
Posted Apr 09, 2020 - 09:42 AEST
Identified
The issue is limited to a small set of recipients. Mailflow in general is working normally and we are working on ensuring the small number of affected recipients are receiving email OK.
Posted Apr 08, 2020 - 12:50 AEST
Investigating
Mail being sent through MPmail is failing to deliver. We are trying to find out what's causing this and will endeavour to provide updates as soon as we have more info.
Posted Apr 08, 2020 - 12:24 AEST
This incident affected: MPmail.