Unable to provision Office 365 licenses for some tenants
Incident Report for Manage Protect Pty Ltd
Resolved
Provisioning now working again.
Posted Sep 10, 2019 - 15:52 AEST
Investigating
We are currently investigating this issue.
Posted Sep 10, 2019 - 15:21 AEST
This incident affected: Office 365 and Converge.