Backup365 maintenance
Incident Report for Manage Protect Pty Ltd
Resolved
Maintenance is complete.
Posted 4 months ago. Aug 04, 2017 - 11:30 AEST
Monitoring
We are doing a brief maintenance deployment to improve stability, responsiveness and speed of the platform. Estimated 30 minutes, the service will be unavailable for this time however scheduled and running backups are not effected.
Posted 4 months ago. Aug 04, 2017 - 11:12 AEST